27 Agustus 2018

Script Auto-Upgrade Versi MikroTik RouterOS

Karena mulai bermunculan celah & kerentanan keamanan di MikroTik ROS. Pihak developer terus memberikan patch upgrade untuk memperbaiki bugs & vulnerability di Mikrotik ROS. Berikut Cara otomatis upgrade versi mikrotik routeros Anda menggunakan fitur "Scheduler & Script" di mikrotik. Agar Anda selalu mendapatkan update terbaru penambahan atau perbaikan dalam setiap versi routerOS yang dikeluarkan secara otomatis.

Script Auto-Upgrade Versi MikroTik RouterOS


Cara Otomatis Upgrade Versi Mikrotik RouterOS


Untuk di perhatikan auto-upgrade ini adalah otomatis, yang membuat Anda tidak melihat perubahan atau penambahan pada versi terbarunya (change-log).
  • Perubahan fitur, seperti di versi sebelumnya ada fitur "abcd" yg anda pakai setelah anda upgrade ternyata fitur "abcd" di hilangkan. Hasilnya anda harus koreksi kembali settingan karena menggunakan update terbaru.

/system scheduler
add interval=2d name=auto_update_ros on-event="/system package update\r\
    \ncheck-for-updates once\r\
    \n:delay 1s;\r\
    \n:if ( [get status] = \"New version is available\") do={ install }" \
    policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
    start-date=aug/27/2018 start-time=02:00:00

Dengan "Scheduler" di atas, scripts akan berjalan untuk cek versi terbaru setiap 2 hari sekali (interval=2d) pada Jam 2 Pagi (start-time=02:00:00) jika script mendapatkan status "New version is available" paket upgrade akan otomatis di download dan di upgrade.

Scripts Upgrade MikroTik ROS

Script berfungsi untuk v6.31 keatas, script akan me reboot mikrotik Anda tanpa konfirmasi jika di temukan versi terbaru.

/system package update
check-for-updates once
:delay 1s;
:if ( [get status] = "New version is available") do={ install }

Atau bisa via winbox di System -> Packages