Dengan Maraknya bisnis RT RW Net dan WiFi Voucher-an, banyak pemilik yang ingin menampilkan informasi pemberhentian layanan internet melalui halaman isolir mikrotik kepada pelanggan voucher hotspot atau PPPoE yang expired atau terlambat membayar melewati jatuh tempo pembayaran.

Pada kesempatan kali ini saya akan coba mencontohkan bagaimana mengalihkan pelanggan hotspot dan PPPoE yang expired ke halaman isolir ketika user mengakses suatu website sekaligus memutuskan koneksi internet mereka sampai pembayaran diselesaikan. Disini saya akan menggunakan fitur web proxy mikrotik dan redirect NAT.

Cara Membuat Halaman ISOLIR di Web Proxy MikroTik

Karena ini menggunakan fitur web proxy, langkah pertama adalah mempersiapkan design halaman isolir di web proxy mikrotik agar dapat ditampilkan ke pelanggan saat akses sebuah website.

Halaman Isolir Mikrotik

Pertama, aktifkan web proxy mikrotik.

aktifkan web proxy mikrotik

Pada menu winbox klik menu IP > Web Proxy

  • Centang pada opsi “Enabled“. Pada contoh gambar diatas saya mengganti Port menjadi 9090.
  • Klik tombol “Access“.
  • Isi Pool IP Address yang mau di isolir pada kolom “Src. Address“. Disini saya menggunakan IP 10.30.8.0/24 untuk nantinya diberikan ke pelanggan expired.
  • Pilih paramater “deny” pada kolom “Action“.

Konfigurasi diatas bertujuan agar Pool IP yang akses website dipaksakan melewati web proxy menampilkan halaman error karena pada parameter Access kita tolak atau “deny“. Halaman error tersebut kita ganti dengan design halaman isolir yang sudah buat.

Upload Halaman ISOLIR ke Webproxy MikroTik.

Selanjutnya kita ganti halaman error default webproxy mikrotik yang tersimpan di storage mikrotik pada File > folder Webproxy > file error.html dengan design halaman isolir yang sudah kita siapkan.

Upload Halaman Isolir MikroTik ke Webproxy

Atau Anda bisa download template halaman isolir yang digunakan pada contoh artikel ini, kemudian upload ke mikrotik Anda.

Cara ISOLIR Pelanggan PPPoE Expired di MikroTik

Selanjutnya kita mempersiapkan konfigurasi isolir pada pelanggan PPPoE Mikrotik, karena pada umumnya mereka berlangganan bulanan.

Membuat Pool IP Address

Langkah ini kita mempersiapkan range/pool ip address yang nantinya digunakan oleh pelanggan expired atau telat bayar.

Pool IP Pelanggan ISOLIR Mikrotik

Mengikuti dari awal tutorial, IP Address yang nanti di dapat oleh pelanggan PPPoE isolir adalah 10.30.8.2-10.30.8.250.

Membuat User Profile PPPoE

Selanjutnya kita buat lagi user profile yang digunakan nantinya oleh pelanggan isolir.

User Profile Pelanggan ISOLIR

Pada menu winbox PPP > Profiles > buat baru user profile pppoe untuk pelanggan isolir.

  • Isi nama profile pada kolom “Name:“.
  • Isi IP Address local si mikrotik pada kolom “Local Address:“, contoh disini saya isi 10.30.8.1.
  • Pilih Pool IP yang sebelumnya kita buat “PPPoE_Expired“.
  • Isi / pilih pada parameter Address List, agar IP pelanggan pppoe yang isolir masuk ke Address List tersebut.

Isolir Pelanggan Yang Telat Bayar

Setelah membuat User Profile untuk pelanggan expired, kita tinggal mengarahkan atau mengganti Profile pada username password pelanggan PPPoE ke User Profile PPPoE_Expired.

Isolir Pelanggan PPPoE Mikrotik

Langkah terakhir, kita setting transparent web proxy atau mengarahkan akses website port 80 & 443 di redirect ke port webproxy dan blokir total koneksi internetnya.

Redirect Pelanggan PPPoE Isolir ke Webproxy.

/ip firewall nat
add action=redirect chain=dstnat comment="Redirect Pelanggan PPPoE Isolir ke Webproxy" dst-port=\
    80,443 protocol=tcp src-address=10.30.8.0/24 to-ports=9090

Blokir Koneksi Internet

/ip firewall filter
add action=drop chain=forward comment="Blokir Koneksi Internet Pelanggan PPPoE ISOLIR" \
    out-interface=ETH1-ISP1 src-address=10.30.8.0/24

4 Comments

  1. mau tanya bang , cara menampilkan folder web proxy di file gimana ya ? saya cari di file gada folder web proxy soalnya

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan.