Cara Setting Bonding Interface di MikroTik

Bonding adalah teknologi yang memungkinkan agregasi dari beberapa interface ethernet menjadi sebuah satu link virtual, sehingga bisa mendapatkan kecepatan data/bandwidth yang lebih besar dan bisa menjadi link failover.

Contoh Dasar Setting Bonding Interface di MikroTik


Mari kita asumsikan bahwa kita memiliki 2 port ether di setiap router (Router 1 dan Router 2) dan ingin mendapatkan data rate/bandwidth maksimum antara kedua router tersebut. Untuk contoh setting bonding di mikrotik, ikuti langkah berikut :
   ether2 ================================== ether2
   MikroTik1 <<==== bonding interface ====>> MikroTik2
   ether3 ================================== ether3

Setting Bonding Interface di Router 1


Tambahkan bonding interface dan IP Address :
/interface bonding 
 add \
  slaves=ether2,ether3 \
  disabled=no
  
/ip address 
 add \
  address=192.168.200.1/24 \
  interface=bonding1 \
  disabled=no

Setting Bonding Interface di Router 2


Tambahkan bonding interface dan IP Address :
/interface bonding 
 add \
  slaves=ether2,ether3 \
  disabled=no
  
/ip address 
 add \
  address=192.168.200.2/24 \
  interface=bonding1 \
  disabled=no

Test koneksi/link dari router 1 ke router 2 :
[adam@Mikrotik1] interface bonding> ping 192.168.200.2
192.168.200.2 ping timeout
192.168.200.2 ping timeout
192.168.200.2 ping timeout
192.168.200.2 64 byte ping: ttl=64 time=2 ms
192.168.200.2 64 byte ping: ttl=64 time=2 ms

Sekarang kita coba test bandwidth antar router mikrotik melalui interface yang di bonding, untuk melihat data rate/bandwidth maksimum yang dihasilkan

Setting Bonding Interface di MikroTik

Terlihat saat test bandwidth dari mikrotik 1 ke mikrotik 2 di kedua interface (ether2 dan ether3) Rx maksimum 100Mbps pada masing-masing ether dan pada interface bonding mendapatkan speed Rx 200Mbps.


Cara Setting Link Monitoring / Failover Bonding Interface


Seperti yang saya sebutkan sebelumnya, dengan mengaplikasikan bonding interface berfungsi juga sebagai failover. Dalam contoh di atas, jika salah satu link putus, bonding akan terus mengirim paket melalui link yang putus dan akan menyebabkan degradasi jaringan. Dengan alasan tersebut link monitoring pada bonding interface harus di aktifkan, contoh disini saya menggunakan ARP Monitoring.

Mengaktifkan ARP Monitoring di Kedua Mikrotik


Router 1
/interface bonding set 0 link-monitoring=arp arp-ip-targets=192.168.200.2

Router 2
/interface bonding set 0 link-monitoring=arp arp-ip-targets=192.168.200.1

Cabut salah satu kabel untuk test apakah link monitoring bekerja dengan benar, Anda akan melihat beberapa timeout sampai arp monitoring mendeteksi putus link.


EmoticonEmoticon