Cara Setting Fitur Email di MikroTik

Tool Email di mikrotik adalah fitur untuk mengirim email dari router mikrotik menggunakan SMTP server, fitur ini dapat digunakan untuk mengirim backup konfigurasi dan mengirim notifikasi kondisi jaringan untuk keperluan monitoring ke admin jaringan. Tentu saja hal ini adalah salah satu cara monitoring agar bisa me respon keadaan atau masalah pada jaringan dengan cepat.

Pada RouterOS Mikrotik, konfigurasi SMTP server untuk kirim email dari mikrotik hanya mendukung plain authentication dan TLS encryption. Kita bisa memanfaatkan SMTP Server dari GMAIL yang gratis untuk menggunakan fitur email mikrotik yang digunakan pada contoh di artikel ini.

Cara Setting SMTP Gmail di Tool Email MikroTik

Mempersiapkan Akun GMAIL

Pertama, yang dibutuhkan adalah tentu saja account gmail aktif yang bisa digunakan. Aktifkan terlebih dahulu fitur POP pada account Gmail Anda, dan aktifkan “Akses aplikasi yang kurang aman” di link https://myaccount.google.com/lesssecureapps karena kita menggunakannya di luar platform Gmail.

Gmail setting Mikrotik

Setting Email di MikroTik

Kedua, isi parameter-parameter SMTP Server gmail di Mikrotik. Pada winbox pilih menu Tools >> Email.

Setting Email di MikroTik

Server: smtp.gmail.com
Port: 587
Start TLS: yes
From: isi email alias pengirim
User: isi alamat gmail Anda.
Password: isi password gmail Anda.
Klik “Apply

Test Kirim Email dari MikroTik

Selanjutnya kita test kofigurasi email apakah sudah benar dengan mencoba kirim email dari mikrotik.

Test Kirim Email dari MikroTik

Pilih “Send Email“.
Centang opsi “TLS“.
isi alamat email penerima pada kolom “To:“.
Isi subject email di kolom “Subject:“.
Isi body email di kolom “Body:“.
Klik “Send Email“.

Jika sukses Anda menerima email di inbox alamat email penerima.

Contoh Menggunakan Tools Email di Mikrotik

Setelah kita konfigurasi settingan email agar mikrotik bisa kirim pesan email, selanjutnya saya akan mencontohkan penggunaan fitur email untuk mengirim backup konfigurasi dan mengirim notifikasi kondisi jaringan untuk keperluan monitoring.

Cara Backup Mikrotik ke Email Otomatis

Pada artikel saya sebelumnya yang menjelaskan 3 Cara Backup & Restore Konfigurasi MikroTik, berikut ini adalah cara lain untuk backup script mikrotik melalui email. Backup script mikrotik otomatis ini bisa berguna jika konfigurasi mikrotik Anda dinamis.

Contohnya jika Anda bisnis voucher mikrotik menggunakan mikhmon, mikhmon aplikasi billing berbasis API yang tidak menyimpan informasi voucher pada server tapi melakukan perubahan menambahkan/mengurangi voucher username di mikrotiknya. Jika rotasi pembuatan voucher Anda tinggi setiap harinya, backup script mikrotik otomatis ini berguna untuk jaga-jaga jika router Anda bermasalah.

Contoh script ini akan backup mikrotik setiap 24 jam, dan file hasil di kirim ke email.

/system scheduler
add interval=1d name=backup_mikrotik_otomatis_email on-event="/export compact file=backup_mikrotik_otomatis\r\
    \n/tool e-mail send to=\"[email protected]\" subject=\"\$[/syste\r\
    \nm identity get name] Backup MikroTik\" body=\"\$[/system clock get date] backup file\"\r\
    \n file=backup_mikrotik_otomatis.rsc\r\
    \n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=\
    nov/25/2021 start-time=15:12:17

Anda bisa sesuaikan pada parameter “Interval” dan ganti alamat email “send to=” ke alamat email Anda.

Kirim Notifikasi via Email untuk Monitoring IP Perangkat Dengan Netwatch

Selanjutnya Anda bisa kirim notifikasi ke email untuk monitoring perangkat jaringan dengan Netwatch Mikrotik. Misalnya anda mempunyai server lokal yang ingin dimonitoring uptimenya, contoh disini memonitoring IP DNS google 8.8.8.8. Jika host/IP tersebut down/up, mikrotik akan mengirim notifikasi via email.

/tool netwatch
add down-script="/tool e-mail send to=\"[email protected]\" subject=\"Warning, DNS Google Dow\
    n!\" body=\"Please Fix it!\"" host=8.8.8.8 interval=10s up-script="/tool e-mail send to=\"modal\
    [email protected]\" subject=\"DNS Google Up!\" body=\"Congratulation bro!\""
Kirim Notifikasi via Email untuk Monitoring IP Perangkat Dengan Netwatch
Hasil Notifikasi di Inbox Email Anda

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan.