26 July 2020

Cara Setting Konfigurasi DNS Over HTTPS (DoH) di Mikrotik Router

Di kesempatan kali ini saya ingin mencontohkan setting & konfigurasi DNS Over HTTPS (DoH) di Mikrotik Router. Sebuah fitur baru yang ditambahkan pada versi RouterOS 6.47 dengan menambahkan dukungan untuk request remote DNS lewat protocol HTTPS.

Alasan kenapa kita membutuhkan fitur DoH (DNS over HTTPS) adalah untuk meningkatkan privasi dan keamanan dengan mencegah penyadapan dan manipulasi data DNS oleh pihak ketiga, dengan menggunakan protokol HTTPS dapat mengenkripsi data antara klien DoH dan resolver DNS DoH.

Cara Setting Konfigurasi DNS Over HTTPS (DoH) di Mikrotik Router


Contoh simplenya untuk merasakan menggunakan fitur DoH seperti Batasan akses situs yang dilakukan oleh ISP dengan redirect dns request ke DNS Server yang di tentukan ISP, seperti contoh di artikel Cara Setting Redirect / Forwarding DNS di MikroTik & Redirect DNS Hotspot MikroTik yang dapat "memaksakan" request dns ke IP DNS Server yang kita mau. Jadi walaupun settingan IP DNS di user di ganti-ganti akan tetap mengarah ke dns server yang sudah ditentukan.

Atau seperti yang dilakukan oleh provider-provider internet di Indonesia yang melakukan filtering akses situs menggunakan redirect dns request yang tidak di perbolehkan oleh pemerintah.

Bahasa alusnya kurang-lebih kalau pakai DoH bisa di bilang "Bypass Filtering ISP"


Langkah Setting Konfigurasi DNS over HTTPS (DoH) di Mikrotik


Pertama, Karena fitur ini tersedia pada RouterOS versi 6.47++ jadi Anda harus upgrade RoS anda ke versi yang terbaru.

[Winbox] System -> Packages -> Check for Updates

Upgrade routeros mikrotik

Kedua, hilangkan/kosongkan IP DNS server di IP -> DNS -> Server. Dan hilang kan juga checklist "User Peer DNS" jika Anda menggunakan DHCP Client pada eth WAN/Internet anda.

Ketiga, menentukan DoH Server yang mau anda gunakan. Anda bisa menggunakan layanan Google atau Cloudflare.
Tambahkan URL yang disediakan pada klom “Use DoH Server” dan ceklis pada “Verify DoH Certificate
Untuk Google -> https://dns.google/dns-query
untuk Cloudflare -> https://cloudflare-dns.com/dns-query
DNS over HTTPS (DoH) Mikrotik

Keempat, buat Static DNS untuk hostname DoH yang digunakan
Google
/ip dns static
add address=8.8.8.8 name=dns.google type=A
add address=8.8.4.4 name=dns.google type=A

Cloudflare
/ip dns static
add address=104.16.248.249 name=cloudflare-dns.com type=A
add address=104.16.249.249 name=cloudflare-dns.com type=A


Kelima, karena Anda ceklist "Verify DoH Certificate" diperlukan untuk download dan Import certificates ke mikrotik router Anda

/tool fetch url=https://curl.haxx.se/ca/cacert.pem
/certificate import file-name=cacert.pem passphrase=””

Cek pada System -> Certificate

DoH Certificate Mikrotik

Langkah terakhir, kita pastikan apakah DoH yang kita konfigurasi sudah bekerja dengan baik. Mudahnya jika anda menggunakan Indihome coba buka situs reddit.com atau Netflix.com. Jika kedua website tersebut masih belum bisa di akses ada langkah yang mungkin terlewat.

Bisa juga membandingkan sebelum & sesudah memakai DoH dengan menggunakan web tools di www.dnsleaktest.com, hasilnya akan seperti ini jika menggunakan DoH Google.

dnsleak doh google