24 Oktober 2015

Cara Setting Terima/Kirim SMS Dengan Modem 3G/CDMA di MikroTik

Salah satu fitur menarik yang ada di MikroTik, yaitu fitur menerima dan mengirim sms dengan modem 3G/4G/CDMA layaknya hp smartphone yang bisa juga mengirim atau menerima pesan SMS. Untuk menggunakan fitur tentu saja memerlukan provider/sim card aktif yang terpasang di modem 3G/4G/CDMA yang terpasang pada Port USB router mikrotik Anda.

Trus fungsinya apa router MikroTik bisa menerima atau mengirim pesan SMS melalui modem 3G ? Untuk Anda ketahui, Router MikroTik dapat menjalankan perintah/command/script jika menerima "keyword" pada pesan SMS yang diterima misalnya :

  • Me reboot router MikroTik. 
  • Mengganti & reset username password router. 
  • Merubah limit pada queue, bandwidth management router. 

Trus fungsi MikroTik bisa mengirim pesan SMS apa? Router MikroTik dapat memberikan informasi ke HP/Gadget Anda menggunakan pesan SMS misalnya :
  • Kondisi koneksi internet Anda.
  • Mengetahui jumlah user hotspot yang sedang aktif. 
  • Atau monitoring koneksi link server-server Anda. 

Dengan fitur ini cukup menarik bukan? menjadi lebih mudah dan fleksible dalam memanajemen jaringan kita. Banyak yang dapat dilakukan dengan fitur SMS ini selain yang saya sebut diatas, karena fungsi ini dipadukan dengan fitur "Scripts" yang ada di router MikroTik. Didalam "Scripts" tersebut anda bisa jalankan atau mengaktifkan beberapa perintah yang sudah Anda buat hanya dengan pesan SMS. Berikut Cara Setting Terima/Kirim SMS Dengan Modem 3G/CDMA di MikroTik.


Terima/Kirim SMS Dengan Modem 3G/CDMA di MikroTik

Untuk contoh tutorial dalam penggunaan fitur SMS di MikroTik ini saya menggunakan :
  • Mikrotik RB751U
  • Modem 3G Huawei E153
  • Kartu Axis
Tidak semua merk modem 3G/4G/CDMA yang disupport oleh MikroTik OS.

Pertama, kita pasang modem 3G yang terpasang SIM CARD pada port USB routerboard / PC mikrotik Anda. Kemudian kita lihat apakah modem kita terdeteksi oleh OS MikroTik.

Pada Winbox pilih menu  System > Resources > pilih USB, jika modem Anda disupport oleh OS MikroTik akan terlihat seperti ini.

resource usb mikrotik

Lanjut ke System > Port di winbox, atau gunakan perintah "port print" pada terminal.

[admin@modalsemangat.com] > /port print
Flags: I - inactive 
 # NAME CHANNELS USED-BY        BAUD-RATE
 0 usb1 4        PPP  9600 
[admin@adamonline.web.id] >

Terlihat port "usb1" yang dikenali mikrotik dipakai oleh modem Anda.

Sekarang ke Tools > SMS

SMS Tools Mikrotik

SMS Setting
Receive Enabled : Centang agar mikrotik dapat menerima SMS.
Port : pilih "usb1" atau port yang muncul di System > Port
Channel : isi dengan channel modem Anda yang terdeteksi. Setiap modem kadang beda-beda.
Secret : contoh 123456, (Ini berfungsi sebagai password yang digunakan untuk menjalankan script/command ketika mikrotik menerima pesan SMS)
Allowed Number : hanya nomor terdaftar yang bisa mengirim sms ke mikrotik. 
Keep Max SMS : Jumlah total pesan SMS yang di bisa disimpan oleh mikrotik. 

Klik Apply

Cara Test Kirim SMS Menggunakan MikroTik

Sekarang kita akan test mencoba mengirim pesan SMS menggunakan Router MikroTik. Pada winbox klik menu Tools > SMS > pilih Send SMS.

Send SMS MikroTik

Send SMS
Phone Number : isi no hp yang akan menerima sms dari mikrotik. 
Message : isi pesan sms agan
Klik Send SMS

Jika berhasil, nomor hape tujuan akan menerima SMS tersebut

dan lihat hape agan terima deh smsnye (note: kondisi modem tidak digunakan koneksi internet router yah)


Menjalankan Script/Perintah Saat MikroTik Menerima SMS

Untuk menjalankan script/perintah saat mikrotik menerima SMS, pastikan pada opsi "Receive Enabled" di centang.

Reboot Router MikroTik dengan SMS

Jika anda ingin mereboot mikrotik remote jarak jauh menggunakan SMS, sebelumnya anda harus membuat "Scripts" pada menu winbox System > Scripts dengan nama "reboot" yang berisi command "/system reboot".

/system script \
    add \
      name=reboot \
      policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
      source=”/system reboot”

Kemudian Anda coba mengirim pesan SMS dengan format dibawah ke nomor SIM CARD yang terpasang di modem 3G MikroTik.

:cmd adamonline.web.id script reboot

Penjelasan dari command diatas :

:cmd = ngasih tau mikrotik untuk jalanin command
adamonline.web.id = adalah password yang kita setting di SMS setting
script = ngasih tau mikrotik untuk menjalankan script
reboot = nama script yang barusan yang kita buat tadi

Monitoring Koneksi Internet

Anda bisa monitoring koneksi internet yang dipadukan dengan fitur  "Netwatch - Scripts - SMS" jadi jika koneksi internet Anda bermasalah atau kembali normal. Router mikrotik akan mengirim pesan SMS informasi kondisi jaringan internet Anda, Sebagai contoh monitoring salah satu DNS Google pada host netwatch, jika timeout/terputus "Netwatch" akan menjalankan "Scripts" yang bernama "down" yang berisi perintah mengirim pesan SMS bahwa koneksi internet anda bermasalah. Atau pun sebaliknya saat kembali normal "Netwatch" akan menjalankan "Scripts" yang bernama "up" yang berisi perintah mengirim pesan SMS bahwa koneksi internet sudah kembali normal.

Contoh Script :

Netwatch
/tool netwatch
    add \
      disabled=no \
      host=8.8.8.8 \ 
      down-script=”/sys script run down” \
      up-script=”/sys script run up” \
      interval=5m \
      timeout=1s

Scripts
/system script
    add \
      name=down \
      policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
      source=”/tool sms send message=Woi,Internet Mati phone-number=08999025197 usb1” \
    add \
      name=up \
      policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
      source=”/tool sms send message=Woi,Internet Dah Idup phone-number=08999025197 usb1”


Mengetahui Jumlah User Hotspot Yang Sedang Aktif

Anda bisa juga mengetahui jumlah user hotspot mikrotik yang sedang aktif melalui SMS, contoh script :
#get time date and active users
:local date [/system clock get date];
:local time [/system clock get time];
:local active [/ip hotspot active print count-only];
:log info "";
:log info "$active active users at $time - $date";
/tool sms send usb2 channel=0 phone-number="+628562255444" message="$active active users at $time - $date"
:log info "Sending active users to sms";
:log info "";

hasilnya di sms inbox hp anda :
25 active users at 20:22:36 - apr/05/2014

Dan hasilnya Anda bisa lebih fleksibel dan lebih mudah dalam memanajemen jaringan mikrotik Anda.

Cara Mengaktifkan Kembali "receive-enabled" via script

Pada opsi "Receive Enabled" akan otomatis off setelah anda reboot router mikrotik, anda bisa jadwalkan dengan script yang dijalankan setelah reboot dan setiap 15 menit.
/system script add name=enable-sms-rec policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    source=”/tool sms set receive-enabled=yes;”

Lanjut buat schedule agar script yang tadi aktif setiap 15 menit, dan juga saat start up setelah reboot.
/system scheduler
add comment=”execute enable-sms-rec script” disabled=no interval=15m name=\
    “execute enable-sms-rec script” on-event=enable-sms-rec policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api \
    start-time=startup