17 Oktober 2015

Cara Setting Fitur Email Di MikroTik

Fitur email di mikrotik adalah fitur yang memungkinkan untuk mengirim e-mail dari router mikrotik. Tool ini dapat digunakan untuk mengirim backup konfigurasi ke admin jaringan atau mengirim notifikasi pada kondisi jaringan tertentu.

Cara Setting Email di MikroTik


Pertama, kita setting informasi account email yang akan digunakan untuk mengirim email dari router mikrotik. Contoh disini saya menggunakan account Gmail karena kirim e-mail dengan account gmail ke server harus menggunakan enkripsi TLS / SSL dengan port 587.

/tool e-mail
set address=[:resolve smtp.gmail.com] from=<mikrotik@emailmu.com> password=rahasiadonk port=587 start-tls=yes \
    user=adam.rachmad@gmail.com

Untuk account gmail, masuk ke settingan Gmail anda dan mengaktifkan fitur POP, dan gunakan starttls=yes, menggunakan port 587, Anda juga harus resolve DNS untuk smtp.gmail.com untuk memastikan IP berapa yang dipakai smtp gmail. Di contoh ini saya menggunakan perintah [:resolve smtp.gmail.com] pada "set address=".

Kedua, cara test mengirim e-mail menggunakan perintah dengan atribut tls set ke yes, karena pakai account gmail

/tool e-mail send to=mikrotik@emailmu.com subject="test kirim email dari mikrotik" body="sukses gan!" start-tls=yes

Cara Troubleshooting Email Di MikroTik


Aktifkan logging untuk layanan email

/system logging add topics=e-mail action=memory

Ini akan memperlihatkan log e-mail dalam log sistem, dan membuat troubleshooting lebih mudah.

Contoh Monitoring Host / IP Dengan Notifikasi via Email


Salah satu contoh memanfaatkan fitur email di mikrotik untuk memonitoring salah satu host/server dengan netwatch, contoh disini dns google 8.8.8.8. Jika host tersebut down/up, mikrotik  akan mengirim notifikasi via email seperti gambar dibawah ini :

Contoh Monitoring Host / IP Dengan Notifikasi via Email


/tool netwatch
add disabled=no down-script="/tool e-mail send to=mikrotik@emailmu.com subject=\"Warning\
    , DNS Google Down!\" body=\"Please Fix it!\" start-tls=yes" host=8.8.8.8 interval=10s \
    timeout=1s up-script="/tool e-mail send to=mikrotik@emailmu.com subject=\"DNS Google\
    \_Up!\" body=\"Congratulation bro!\" start-tls=yes"