25 September 2015

Cara Setting Redirect / Forwarding DNS di MikroTik



Di Kesempatan ini, saya akan menjelaskan tehnik setting pengalihan / forwarding DNS di Mikrotik untuk komputer klien. Anggap saja Anda mempunyai rencana bahwa dalam jaringan komputer warnet Anda tidak memperbolehkan mengakses situs-situs yang "ga bener", mungkin hal yang paling mudah adalah blokir / filter situs "ga bener" dengan DNS.

Banyak perusahan ISP yang sudah memfilter akses situs dengan DNS mereka, contohnya yang mungkin anda tahu yaitu filter situs "ga bener" dengan DNS Nawala. DNS Nawala menawarkan layanan DNS yang bebas digunakan oleh pengguna atau penyedia jasa internet untuk mendapatkan akses internet bersih dan aman.

Anda setting IP DNS di tiap komputer client dgn DNS tersebut atau hanya anda arahkan ke DNS IP mikrotik anda ? yang jadi pertanyaan,  bagaimana jika si user mengganti settingan IP DNS di komputernya sendiri ? seperti contoh dalam artikel saya di 6 Cara Bypass Filtering dan Sensor Internet

Berikut penyedia jasa DNS Filtering internet yang akan membuat penggunaan Internet sehat dengan menggunakan penyaringan konten web yang terintegrasi, anti-phising, Blok Situs dan anti pornografi.

AmalaDNS - http://www.amaladns.com
  • 202.146.225.215
  • 202.146.225.216

Nawala - http://www.­nawala.­org
  • 180.131.144.144
  • 180.131.145.145

Tehnik Setting Redirect / Forwarding DNS di Mikrotik


Nah ada solusi di dalam mikrotik yang dapat "maksain" request DNS dari user ke IP DNS mikrotik agar menggunakan DNS yang kita inginkan menggunakan tehnik setting redirect / forwarding DNS di MikroTik. Cukup tambahkan rules di IP > Firewall > NAT seperti ini:

/ip firewall nat
add action=redirect chain=dstnat comment="" disabled=no dst-port=53 protocol=tcp to-ports=53
add action=redirect chain=dstnat comment="" disabled=no dst-port=53 protocol=udp to-ports=53

Rules diatas akan meredirect (memaksa) permintaan DNS (port 53) dri komputer user ke DNS mikrotik. jadi walaupun user mengganti2 DNS akan tetap menggunakan DNS yg kita setting di IP > DNS router mikrotik Anda.