Cara Setting NAT Public Passive FTP Server FreeNAS di MikroTik

Jika Anda membangun sebuah Public FTP Server contoh menggunakan FreeNAS, dan dibelakang NAT router MikroTik. FTP Server Anda menggunakan misalnya lokal IP 192.168.1.10 dan ingin bisa di akses di cloud internet (Public FTP Server) dengan menggunakan teknik NAT forwarding di mikrotik. Berikut contoh cara setting NAT Forwarding FTP Server FreeNAS di MikroTik.

Setting NAT Public Passive FTP Server FreeNAS Behind MikroTik Router

Jika anda akses langsung ftp server anda menggunakan file/internet explorer, muncul error "An error occurred opening that folder on The FTP Server. Make sure you have permission to access that folder. 227 Entering Passive Mode" Hal ini dikarenakan FTP Server anda dibelakang NAT/Router MikroTik.

Berbeda jika anda akses dari FTP client di jaringan lokal Anda, anda tidak menemukan masalah ini.

Entering Passive Mode

Sebelum lanjut, untuk diketahui FTP server itu beroperasi menggunakan 2 port.
  • Port command (standarnya port 21) -> untuk tranfer command.
  • Port data -> untuk transfer data (nomor portnya ditentukan saat akan transfer data).
Dalam contoh ini, saya menggunakan IP Address :
222.222.222.222 adalah IP Public Anda.
192.168.1.10 adalah IP Local FTP Server Anda.

Setting Passive Mode FTP Server FreeNAS


Pertama, kita akan set FTP Server kedalam passive mode, menentukan Minimal & Maximal Port Passive Mode FTP Server Anda. Pada service FTP freenas anda akan menemukannya di "Advances Setting"


Passive Mode FTP Server FreeNAS

Masquerade address : 222.222.222.222 (isi IP Public Anda)
Minimum passive port : 15000
Maximum passive port : 15100 (range portnya tentukan dari banyaknya client yang akan akses ke FTP server anda)

Setting NAT Forwarding di MikroTik


Kedua, anda setting NAT forwarding di MikroTik Anda. Jangan lupa bahwa FTP Server beroperasi menggunakan 2 port, tidak cukup jika Anda hanya forward port 21.

Di Mikrotik tambahkan setting dst-nat :

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.1.10 to-ports=21 protocol=tcp dst-address=222.222.222.222 in-interface=WAN dst-port=21 log=no log-prefix=""
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.1.10 to-ports=15000-15100 protocol=tcp dst-address=222.222.222.222 in-interface=WAN dst-port=15000-15100 log=no log-prefix=""
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.1.10 to-ports=15000-15100 protocol=udp dst-address=222.222.222.222 in-interface=WAN dst-port=15000-15100 log=no log-prefix=""

dan tambahkan src-nat agar FTP Server keluar menggunakan IP Public yang ditetapkan.

/ip firewall nat
add action=src-nat chain=srcnat out-interface=WAN src-address=192.168.1.10 to-addresses=222.222.222.222

sekarang Anda coba kembali akses login ke Public FTP Server anda menggunakan internet explorer atau file explorer (ftp://222.222.222.222)


EmoticonEmoticon