Cara Membuat User Hotspot MikroTik

Setelah kita sudah mengaktifkan fitur Hotspot MikroTik, sekarang kita akan membuat username hotspot yang akan digunakan untuk login agar bisa mengakses koneksi internet. Di manajemen user hotspot mikrotik kita bisa membuat beberapa user dengan beberapa opsi/batasan.

Dalam artikel ini saya coba mencontohkan membuat user hotspot mikrotik dengan beberapa batasan dengan menggunakan manajemen user hotspot internal mikrotik.

Cara Membuat User Hotspot MikroTik

Cara Membuat Username dengan Limitasi Bandwidth/Kecepatan Internet

Anggap saja kita akan membuat batasan kategori user hotspot sebagai berikut :
  • Kategori user VIP, dengan batasan kecepatan koneksi internet Download 1Mbps dan Upload 384Kbps.
  • Kategori user Gold, dengan batasan kecepatan koneksi internet Download 512Kbps dan Upload 256Kbps.
  • Kategori user Silver, dengan batasan kecepatan koneksi internet Download 256Kbps dan Upload 128Kbps.

Yang pertama kita lakukan adalah membuat User Profile pada hotspot mikrotik kita, untuk setting limitasi masing-masing kategori User.

# jun/30/2014 14:33:16 by RouterOS 5.26
# Adam Rachmad - http://adamonline.web.id
/ip hotspot user profile
add advertise=no idle-timeout=none keepalive-timeout=2m name=VIP \
    open-status-page=always rate-limit=512k/1m shared-users=1 \
    status-autorefresh=1m transparent-proxy=yes
add advertise=no idle-timeout=none keepalive-timeout=2m name=Gold \
    open-status-page=always rate-limit=256k/512k shared-users=1 \
    status-autorefresh=1m transparent-proxy=yes
add advertise=no idle-timeout=none keepalive-timeout=2m name=Silver \
    open-status-page=always rate-limit=128k/256k shared-users=1 \
    status-autorefresh=1m transparent-proxy=yes

Di Winbox akan terlihat seperti ini IP > Hotspot > User Profiles :

Username dengan Limitasi Bandwidth/Kecepatan Internet

Setelah itu baru kita buat username dan password untuk kategori user hotspot yang barusan kita buat.

# jun/30/2014 14:33:16 by RouterOS 5.26
# Adam Rachmad - http://adamonline.web.id
/ip hotspot user
add disabled=no name=udin password=123456 profile=VIP server=hotspot1
add disabled=no name=petot password=123456 profile=Gold server=hotspot1
add disabled=no name=jiung password=123456 profile=Silver server=hotspot1

Di menu IP > Hotspot > Users terdapat opsi konfigurasi user / password klien kita yang bisa di konfigurasi.

Tab “General
  • Server, nama server Hotspot yang diperbolehkan login untuk user.
  • Name, Username untuk login user HotSpot, jika otentikasi dengan MAC-addressdi aktifkan, di isi dengan mac address client.
  • Password, password user.
  • Address, masukan IP address yang kita tentukan untuk didapat oleh client dari server hotspot.
  • MAC Address, username diperbolehkan untuk login hanya dari MAC Address yang ditentukan.
  • Profile, User profile yang sudah di konfigurasi di /ip hotspot user profile.
  • Routes, Routing yang ditambahkan jika client terkoneksi. Format routingnya adalah dst-address gateway metric (contoh, 192.168.1.0/24 192.168.88.1 1)
  • Email, alamat email pengguna hotspot.

Tab “Limits”
  • Limit Uptime, Batas Uptime untuk klien HotSpot, client akan terputus dari HotSpot jika uptime tercapai.
  • Limit Bytes In, Jumlah maksimal byte (total quota download) yang dapat diterima oleh client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.
  • Limit Bytes Out, Jumlah maksimal byte (total quota upload) yang dapat diterima oleh client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.
  • Limit Bytes Total, Jumlah maksimal byte (total quota download & upload) yang dapat diterima oleh client. Client akan terputus dari HotSpot setelah batas tersebut tercapai.
Untuk opsi lainnya Anda bisa mencobanya, untuk kasus ini kita hanya membatasi kecepatan internet untuk user hotspot.

Terlihat di winbox akan seperti ini IP > Hotspot > Users :

Username dengan Limitasi Bandwidth/Kecepatan Internet

Sekarang coba login dengan salah satu username passsword tersebut, contoh saya coba login dengan user hotspot “udin” kategori user hotspot VIP.


Terlihat pada gambar di atas bahwa client yang login dengan username “udin” ter limit kecepatannya disesuaikan user profile yang sebelumnya kita buat. Ini berlaku untuk user hotspot lainnya. Di winbox kita bisa lihat di Queues > Simple Queues.

Otentifikasi Login Hotspot Dengan MAC Address Komputer/Laptop Client


Disini kita akan mencoba bagaimana agar komputer/laptop client bisa login otomatis dengan identifikasi MAC Address. Jadi user hotspot tidak perlu username password untuk bisa login ke hotspot mikrotik kita. Ini berbeda dengan fitur Binding/Bypass MAC Address.

Pertama, kita set dulu Server Profilesnya agar bisa otentifikasi dengan mac, IP > Hotspot > Server Profiles > pilih profile yang anda gunakan > tab Login > centang MAC.

Login Hotspot Dengan MAC Address

Kemudian buat user IP > Hotspot > Users > add dan isi Name dngan MAC address komputer/gadget user dan tentukan User Profilesnya.

Otentifikasi Login Hotspot Dengan MAC Address

Client/user tidak akan melihat halaman login hotspot mikrotik Anda (langsung otomatis login), tapi di status hotspot mikrotik kita aktif. Dan limitasi mengikuti user profile yang kita tentukan.

Mengaktifkan MAC Login Hotspot

Cara username hanya bisa digunakan untuk login di MAC Address yang ditentukan

Anggap saja anda ingin 1 username password hanya bisa digunakan untuk login di 1 MAC Address atau di laptop/gadget tertentu (tidak bebas bisa dipakai di komputer lain), jadi komputer/laptop yang mempunyai MAC address berbeda tidak bisa menggunakan username ini.

Berikut adalah cara settingnya :

/ip hotspot user
add disabled=no mac-address=08:00:27:00:A8:E9 name=udin password=123456 profile=VIP \
    server=hotspot1

Jadi username dengan nama “udin” hanya bisa digunakan di komputer/laptop yang mempunyai MAC Address (LAN Card/WiFi08:00:27:00:A8:E9. Jika digunakan di berbeda mac address akan tampil error message seperti dibawah ini :

1 MAC Address 1 Username

Cara Mengaktifkan Fitur Free Trial User Hotspot

Jika anda memberikan layanan koneksi gratis / free trial, dalam mikrotik terdapat fitur Free Trial yang bisa Anda gunakan. User tidak perlu mempunyai username password untuk mengakses koneksi internet via hotspot Anda, cukup 1 klik tombol di halaman login Anda. Fitur ini juga bisa juga digunakan hanya untuk pembatasan penggunaan/uptime internet gratis di lokasi public wifi.

Tentu saja kita tidak memberikan koneksi unlimited untuk user free trial, di mikrotik kita bisa membuat batasan berapa lama bisa terkoneksi (uptime) dan berapa lama bisa digunakan kembali (laptop/gadget yg sama) bisa menggunakan kembali layanan Free Trial (Uptime Reset) jika jatah gratisan sudah habis.

Pada winbox masuk menu IP > Hotspot > Server Profiles. Pilih server profiles yang aktif, jika menggunakan wizard (Hotspot Setup) biasanya namanya "hsprof1". Klik tab "Login" kemudian centang "Trial" untuk mengaktifkan fitur Free Trial (1).

Fitur Login Untuk Free Trial User Hotspot

(2)Opsi pada fitur trial

  • Trial Uptime Limit : Tentukan waktu gratis / free akses yang diberikan ke trial user agan untuk mencoba koneksi hotspot mikrotik agan.
  • Trial Uptime Reset : Tentukan waktu reset trial user, ini maksudnya jika trial user agan sudah memakai semua waktu yang digunakan untuk trial, trial user itu harus menunggu misalnya “1d 00:00:00” atau 24 jam dengan mac address yg sama untuk bisa kembali login menggunakan fungsi Free Trial hotspot mikrotik agan lagi. 
  • Trial User Profile : User profile yang digunakan untuk user trial.
Pada halaman login hotspot, akan muncul tombol/link untuk user Free trial : 

tombol/link untuk user Free trial


EmoticonEmoticon